最新消息:

卸载RPM包时报错specifies multiple packages

rpm admin 504浏览 0评论

当卸载RPM安装包时,系统提示如下错误:

 # rpm -e xxxx-1.1.6-20
error: "sae-om-tools-1.1.6-20" specifies multiple packages:
  xxxx-1.1.6-20.noarch
  xxxx-1.1.6-20.noarch
  xxxx-1.1.6-20.noarch
  xxxx-1.1.6-20.noarch
  xxxx-1.1.6-20.noarch

相同的包安装了多次, 有可能是 rpmdb 数据损坏导致, 请查看 Rpmdb checksum is invalid: dCDPT(pkg checksums):

如何删除重复包:

rpm -e  xxxx-1.1.6-20 --allmatches

 

转载请注明:热门技术 » 卸载RPM包时报错specifies multiple packages

发表我的评论
取消评论
表情

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址